[SVP] Impossible de télécharger/installer des plugins 3.2 via SVP SPIP4 ?

Salut,

j’essaie de télécharger et d’installer des plugins compatibles SPIP 3.2 dans SPIP 4 via SVP mais la recherche ne les trouve pas malgré la compatibilité forcée. Idem en cas de dépendance à un autre plugin. Ex : Duplicator et contact

Une fois téléchargé manuellement dans le dossier plugins (via zip), ils sont bien visibles et peuvent être activés sans problème.

Est-ce que c’est voulu ?

Je pense simplement qu’il n’a jamais été prévu que la recherche SVP utilise la compatibilité forcée. L compatibilité forcée a été rajoutée sans qu’on se pose la question de son utilisation dans la recherche qui elle s’attache à la version du site.

Et je pense que c’est très bien ainsi, cette constante est « une roue de secours » qui permet de tester les plugins en place sur un site, mais ça doit rester temporaire, pas d’en ajouter et de laisser aux gens le risque d’installer des plugins qui ferait exploser leur site en plein vol (a page blanche tout ça).

1 J'aime

Tu me l’as oté de la bouche…

1 J'aime

Ça se tient…
Je pensais juste que la compatibilité forcée concernait également la recherche SVP donc j’ai mis du temps à comprendre pourquoi mes plugins/squelettes ne s’activaient pas (à cause de dépendances de dépendances).

1 J'aime