Socialtags versions incompréhensibles

Hello,

Social tags possèdent 3 branches majeures compatibles avec des versions de spip encore maintenues. La v2 et la v3 sont compatibles avec SPIP 4 sachant que la v2 est aussi compatible avec SPIP 3.0 !

C’est totalement incompréhensible surtout quand on regarde la page Plugins SPIP. Il faudrait vraiment faire attention à cette logique de version et avant de créer des versions à tout va regarder ce qui existe. Lors du passage à la v3, on aurait du clore la v2 à SPIP 3.2 au maximum et se demander si il y avait encore un intérêt à trainer SPIP 3.2 en v3.

Faut vraiment qu’on réfléchisse à comment améliorer cette gestion et à communiquer les pratiques les plus vertueuses.

Yop, la V2 est passée en compat 4.0 par @chankalan ici v2 valide SPIP 4.0.0 (9a328f17) · Commits · spip-contrib-extensions / socialtags · GitLab (je ne souhaite pas balancer hein !)

Ensuite, on peut voir que @marcimat a entamé un ménage dans la v3 avec Une v3 pour 3.2 et 4.0. On enlève du vieux code mort, et on passe le... (6ecad46c) · Commits · spip-contrib-extensions / socialtags · GitLab

Question : est-il trop tard pour revenir en arrière sur la v2 afin de la limiter à SPIP 3.2 max ?

Oui c’est la question.

Alors je transforme ma question en proposition :slight_smile:

La v2 n’a aucune utilité : c’est une v1 dont les bornes de compat ont été modifiées sans aucune autre modification.
Il suffit donc de supprimer les tags de la v2 et d’arrêter de la distribuer


Cédric
Le 19 sept. 2021 à 22:45 +0200, b_b via Discuter de SPIP noreply@discuter.spip.net, a écrit :

b_b
Septembre 19
Alors je transforme ma question en proposition
Voir le sujet ou répondre à ce courriel pour répondre.
Vous recevez ce courriel car vous avez activé la liste de diffusion.
Pour se désabonner de ces courriels, cliquez ici.

ha ben vi, ménage par le vide et zou :slight_smile:

Fait.

1 J'aime