SPIPBB et intégration dans squelette perso

Bonjour

J'ai installé spipbb et après avoir réglé un certain nombre de problème lié à une mauvaise configuration générale de mon site, j'ai 2 interrogations.
    la première est un ennui, quand un utilisateur se loggue pour la première fois le site part dans le décor avec une erreur 500 (page non trouvé) on n'accède pas au forum. Bizarrement le message est enregistré et le problème ne se reproduit plus.
    la deuxième interrogation, est ; comment arriver à intégrer le squelette de spipBB dans mon squelette?

Bon si quelqu'un pouvait éclairer ma lanterne, ce serait vraiment sympa.
Merci

Camille

Pour l'erreur, va poser la question sur le forum de spipBB car je n'ai jamais rencontré cette erreur.

Pour l'inclusion dans ton squelette, j'ai créé un fichier groupeforum.html dans mon dossier squelettes qui correspond à la rubrique qui contient ton forum spipBB et j'ai copié collé le code suivant :

          <!-- #FORUM -->
            <div id="forum">

            <INCLURE{fond=corps_sk/c_rubrique}{id_rubrique}>

          </div>
            <!-- end #FORUM -->

Dans la partie #content de mon fichier groupeforum.html et ainsi de suite pour les fichiers utilisés par SPIPBB (form_inscript.html, liste_messages.html, membres_liste.html etc) tout en jouant sur l'ID css #FORUM.

En fait, il faut créé les fichiers ad hoc dans ton dossier squelettes afin d'avoir ta mise en page. Pour cela, tu vas dans spip/plugins/spipBB/ et là, tu as les fichiers utilisés par spipBB pour l'affichage avec le code utilisé.

Bon courage.

Le 15/10/09 16:27, « Camille » <camille.infographie34@orange.fr> a écrit :

Bonjour

J'ai installé spipbb et après avoir réglé un certain nombre de problème
lié à une mauvaise configuration générale de mon site, j'ai 2
interrogations.
    la première est un ennui, quand un utilisateur se loggue pour la
première fois le site part dans le décor avec une erreur 500 (page non
trouvé) on n'accède pas au forum. Bizarrement le message est enregistré
et le problème ne se reproduit plus.
    la deuxième interrogation, est ; comment arriver à intégrer le
squelette de spipBB dans mon squelette?

Bon si quelqu'un pouvait éclairer ma lanterne, ce serait vraiment sympa.
Merci

Camille

_______________________________________________
liste spip
spip@rezo.net - désabonnement : envoyer un mail à spip-off@rezo.net

Infos et archives : http://listes.rezo.net/mailman/listinfo/spip
http://archives.rezo.net/spip.mbox/

Documentation de SPIP : http://www.spip.net/

Irc : de l'aide à toute heure : http://spip.net/irc

\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_

Jean-Philippe Guihard
Cadre Rééducateur

Association Hospitalière de Bretagne
22110 Plouguernével
02 96 57 10 32
<http://perso.orange.fr/jp.guihard/>
<http://fureurdunoir.free.fr/newfureur/>

Merci pour ta réponse.
En fait le problème est résolu. Les erreurs étaient dues à un mauvaise install de spip2. J'avais omis de supprimer le répertoire écrire lors du passage de spip 1.9 à 2 et quelques anciens fichiers y mettaient la panique.
Le forum avec mise en page perso fonctionne enfin correctement.

GUIHARD Jean-Philippe a écrit :

Pour l'erreur, va poser la question sur le forum de spipBB car je n'ai jamais rencontré cette erreur.

Pour l'inclusion dans ton squelette, j'ai créé un fichier groupeforum.html dans mon dossier squelettes qui correspond à la rubrique qui contient ton forum spipBB et j'ai copié collé le code suivant :

          <!-- #FORUM -->
            <div id="forum">

            <INCLURE{fond=corps_sk/c_rubrique}{id_rubrique}>

          </div>
            <!-- end #FORUM -->

Dans la partie #content de mon fichier groupeforum.html et ainsi de suite pour les fichiers utilisés par SPIPBB (form_inscript.html, liste_messages.html, membres_liste.html etc) tout en jouant sur l'ID css #FORUM.

En fait, il faut créé les fichiers ad hoc dans ton dossier squelettes afin d'avoir ta mise en page. Pour cela, tu vas dans spip/plugins/spipBB/ et là, tu as les fichiers utilisés par spipBB pour l'affichage avec le code utilisé.

Bon courage.

Le 15/10/09 16:27, « Camille » <camille.infographie34@orange.fr> a écrit :

Bonjour

J'ai installé spipbb et après avoir réglé un certain nombre de problème
lié à une mauvaise configuration générale de mon site, j'ai 2
interrogations.
    la première est un ennui, quand un utilisateur se loggue pour la
première fois le site part dans le décor avec une erreur 500 (page non
trouvé) on n'accède pas au forum. Bizarrement le message est enregistré
et le problème ne se reproduit plus.
    la deuxième interrogation, est ; comment arriver à intégrer le
squelette de spipBB dans mon squelette?

Bon si quelqu'un pouvait éclairer ma lanterne, ce serait vraiment sympa.
Merci

Camille

_______________________________________________
liste spip
spip@rezo.net - désabonnement : envoyer un mail à spip-off@rezo.net

Infos et archives : http://listes.rezo.net/mailman/listinfo/spip
Discuter chez rezo.net

Documentation de SPIP : http://www.spip.net/

Irc : de l'aide à toute heure : http://spip.net/irc

\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_

Jean-Philippe Guihard
Cadre Rééducateur

Association Hospitalière de Bretagne
22110 Plouguernével
02 96 57 10 32
<http://perso.orange.fr/jp.guihard/&gt;
<http://fureurdunoir.free.fr/newfureur/&gt;
_______________________________________________
liste spip
spip@rezo.net - désabonnement : envoyer un mail à spip-off@rezo.net

Infos et archives : http://listes.rezo.net/mailman/listinfo/spip
Discuter chez rezo.net

Documentation de SPIP : http://www.spip.net/

Irc : de l'aide à toute heure : http://spip.net/irc