Site SPIP inaccessible !

Bonjour,
J’ai voulu passer un site de 3.2.11 à 4.0.0 et… il est devenu
inaccessible aussi bien en public qu’en privé ! Heureusement le FTP
fonctionne.
Qui a une idée ?
http://septdormants-levieuxmarche.fr/
Merci d’avance !


Philippe Giron

Hum… Je ne suis pas spécialiste… Peut-être un problème de version de PHP ? SPIP 4 nécessite PHP en version >= 7.3 je crois.

Sinon, essaie en renommant les dossiers plugins/ et squelettes/ en plugins_back/ et squelettes_back/.

Des instructions ici pour afficher les erreurs php (temporairement) : Les aides au débuggage de squelettes - SPIP

1 J'aime

Le 23/09/2021 à 23:31, tcharlss via Discuter de SPIP a écrit :

[tcharlss] tcharlss https://discuter.spip.net/u/tcharlss
Septembre 23

Des instructions ici pour afficher les erreurs php (temporairement) :
Les aides au débuggage de squelettes - SPIP
https://www.spip.net/fr_article4453.html#Page-blanche


Voir le sujet
https://discuter.spip.net/t/site-spip-inaccessible/155843/3 ou
répondre à ce courriel pour répondre.

OK.
J’ai le message suivant :

Fatal error: Uncaught Error: Call to undefined function
spip_version_compare() in /home/septdormkp/www/ecrire/inc/plugin.php:216
Stack trace: #0
/home/septdormkp/www/ecrire/plugins/infos_paquet.php(63):
plugin_version_compatible(’[3.1.0;[’, ‹ 3.2.11 ›, ‹ spip ›) #1
/home/septdormkp/www/ecrire/plugins/get_infos.php(122):
plugins_infos_paquet(’<paquet\n\tprefix…’, ‹ auto/yaml/v2.0… ›,
‹ plugins/ ›) #2 /home/septdormkp/www/ecrire/plugins/get_infos.php(66):
plugins_get_infos_un(‹ auto/yaml/v2.0… ›, true, ‹ plugins/ ›, Array) #3
/home/septdormkp/www/ecrire/inc/plugin.php(254):
plugins_get_infos_dist(Array, true, ‹ plugins/ ›) #4
/home/septdormkp/www/ecrire/inc/plugin.php(835):
liste_plugin_valides(Array, true) #5
/home/septdormkp/www/ecrire/inc/plugin.php(764):
ecrire_plugin_actifs(Array, false, ‹ force ›) #6
/home/septdormkp/www/ecrire/inc_version.php(455):
actualise_plugins_actifs() #7 /home/septdormkp/www/spip.php(17):
include_once(’/home/septdormk…’) #8 /home/septdormkp/www/index.php(3):
include(’/home/septdormk…’) #9 {main} in
/home/septdormkp/www/ecrire/inc/plugin.php on line 216

Mais ça ne m’avance pas beaucoup…*
*


Philippe Giron

Nous si :slight_smile:
Ça donne le fichier, la ligne et la fonction exacte qui déclenche l’erreur : c’est l’appel à la fonction spip_version_compare de la ligne 216 du fichier ecrire/inc/plugin.php

Si on regarde la ligne 216 en Spip 4.0, il n’y a rien en rapport avec cette erreur :

$minimum_inc = $intervalle[0] == '[';

En revanche il a bien l’appel à cette fonction dans la version du fichier pour Spip 3.2 :

if ($minimum_inc and spip_version_compare($version, $minimum, '<')) {

Il semblerait qu’il y ait toujours des fichiers Spip 3.2 dans ton installation.
Peut-être que la mise à jour ne s’est pas correctement déroulée et qu’il y a un mélange de fichiers 3.2 / 4.0 ?
En tout cas il faudrait recommencer l’opération.

Le 24/09/2021 à 11:11, tcharlss via Discuter de SPIP a écrit :

[tcharlss] tcharlss https://discuter.spip.net/u/tcharlss
Septembre 24

pgiron:

Mais ça ne m’avance pas beaucoup…

Nous si :slight_smile:
Ça donne le fichier, la ligne et la fonction exacte qui déclenche
l’erreur : c’est l’appel à la fonction |spip_version_compare| de la
ligne 216 du fichier ecrire/inc/plugin.php

Si on regarde la ligne 216 en Spip 4.0
https://git.spip.net/spip/spip/src/branch/4.0/ecrire/inc/plugin.php#L216,
il n’y a rien en rapport avec cette erreur :

|$minimum_inc = $intervalle[0] == ‹ [ ›; |

En revanche il a bien l’appel à cette fonction dans la version du
fichier pour Spip 3.2
https://git.spip.net/spip/spip/src/branch/3.2/ecrire/inc/plugin.php#L216
:

|if ($minimum_inc and spip_version_compare($version, $minimum, ‹ < ›)) { |

Il semblerait qu’il y ait toujours des fichiers Spip 3.2 dans ton
installation.
Peut-être que la mise à jour ne s’est pas correctement déroulée et
qu’il y a un mélange de fichiers 3.2 / 4.0 ?
En tout cas il faudrait recommencer l’opération.

AH OK, je vois cela, je refais une installation propre.
Merci :slight_smile:



Philippe Giron

Le 24/09/2021 à 11:11, tcharlss via Discuter de SPIP a écrit :

[tcharlss] tcharlss https://discuter.spip.net/u/tcharlss
Septembre 24

pgiron:

Mais ça ne m’avance pas beaucoup…

Nous si :slight_smile:
Ça donne le fichier, la ligne et la fonction exacte qui déclenche
l’erreur : c’est l’appel à la fonction |spip_version_compare| de la
ligne 216 du fichier ecrire/inc/plugin.php

Si on regarde la ligne 216 en Spip 4.0
https://git.spip.net/spip/spip/src/branch/4.0/ecrire/inc/plugin.php#L216,
il n’y a rien en rapport avec cette erreur :

|$minimum_inc = $intervalle[0] == ‹ [ ›; |

En revanche il a bien l’appel à cette fonction dans la version du
fichier pour Spip 3.2
https://git.spip.net/spip/spip/src/branch/3.2/ecrire/inc/plugin.php#L216
:

|if ($minimum_inc and spip_version_compare($version, $minimum, ‹ < ›)) { |

Il semblerait qu’il y ait toujours des fichiers Spip 3.2 dans ton
installation.
Peut-être que la mise à jour ne s’est pas correctement déroulée et
qu’il y a un mélange de fichiers 3.2 / 4.0 ?
En tout cas il faudrait recommencer l’opération.

J’ai refais l’installation,ce n’edsty plus bloqué mais j’ai le message
suivant :

Parse error: syntax error, unexpected ‹ ) › in
/home/septdormkp/www/plugins-dist/medias/medias_pipelines.php on line
401

Quand je regarde cette ligne dans le fichier il y a juste: );
Je me demande si ce ne devrait pas être } pour fermer function
medias_calculer_rubriques($flux) (ligne 388)

Ceci dit n’ayant touché à rien je me demande d’où vient cette erreur !*
*



Philippe Giron

Même histoire : c’est la version du plugin pour Spip 3.2.
Par quel moyen as-tu fait la mise à jour ?

Le 24/09/2021 à 12:43, tcharlss via Discuter de SPIP a écrit :

[tcharlss] tcharlss https://discuter.spip.net/u/tcharlss
Septembre 24

pgiron:

/Parse error/: syntax error, unexpected ‹ ) › in
//home/septdormkp/www/plugins-dist/medias/medias_pipelines.php/ on
line
/401/

Même histoire : c’est la version du plugin pour Spip 3.2
https://git.spip.net/spip/medias/src/branch/3.2/medias_pipelines.php#L401.
Par quel moyen as-tu fait la mise à jour ?

Par FTP. Je vais dévalider tous les plugins hors plugins-dist et voir ce
que cela donne.
Re-merci :slight_smile:



Philippe Giron

Le 24/09/2021 à 12:43, tcharlss via Discuter de SPIP a écrit :

[tcharlss] tcharlss https://discuter.spip.net/u/tcharlss
Septembre 24

pgiron:

/Parse error/: syntax error, unexpected ‹ ) › in
//home/septdormkp/www/plugins-dist/medias/medias_pipelines.php/ on
line
/401/

Même histoire : c’est la version du plugin pour Spip 3.2
https://git.spip.net/spip/medias/src/branch/3.2/medias_pipelines.php#L401.
Par quel moyen as-tu fait la mise à jour ?

Par FTP.
J’ai supprimé tout sauf /IMG, renomme tous les plugins pour qu’ils ne
soient plus accessibles dans /plugins/auto, avec un _ en final du nom,
j’ai rechargé SPIP 4.0.0, supprimé /tmp/cache et pourtant je me retrouve
avec ça :
Parse error: syntax error, unexpected ‹ ) › in
/home/septdormkp/www/plugins-dist/medias/medias_pipelines.php on line
401


Philippe Giron

Le problème vient du plugin media dans plugins-dist/

Il faudrait que tu essaies de supprimer son répertoire et de recopier via FTP ce dossier en particulier peut-être.

Voilà mon problème actuel, pourtant j’ai autorisé les cookies…

···

Le 24/09/2021 à 16:29, Brice Boucard via Discuter de SPIP a écrit :

Brice Boucard bricebou
Septembre 24

Le problème vient du plugin media dans plugins-dist/

Il faudrait que tu essaies de supprimer son répertoire et de recopier via FTP ce dossier en particulier peut-être.


-- 
Philippe Giron