[Résolu] SPIP 4.4.18 mise à jour.

Bonjour à tous,

impossible de finaliser la mise à jour,
Serveur OVH, php Version PHP globale 8.4
Mysql : MYSQL v.8.0
Dans le bandeau haut message ;
Erreur d’exécution …/prive/formulaires/recherche_ecrire.html

Puis en popup :
"Message technique :

la procédure de mise à jour doit être lancée afin d’adapter la base de données à la nouvelle version de SPIP.
Si vous êtes admin du site, veuillez"

sans rien d’autre que dois-je faire ?

J’ai eu une erreur similaire, due à une version incompatible du plugin urls_pages.

En renommant le dossier plugins/auto/urls_pages/ en plugins/auto/urls_pages_bak/ (par exemple), tu pourras finaliser la procédure de migration.

Ensuite, il faut récupérer la dernier version (master) du plugin urls_pages et l’installer manuellement sur le serveur ; ou alors attendre la prochaine (imminente) publication de la nouvelle version.

2 « J'aime »

Salut, j’ai eu cette erreur sur un site qui utilise le plugin URLs Pages Personnalisées - Plugins SPIP avec les « URLs Libres ». Je ne sais pas si c’est ton cas, mais désactiver ce plugin permet de passer outre ces erreurs et de lancer la mise à jour de la base. D’ailleurs, il semble qu’un correctif du plugin sur ce point soit dispo fix: inclure la fonction dist sans passer par find_in_path (69bf8d92) · Validations · spip-contrib-extensions / urls_pages · GitLab mais pas encore disponible publiquement sans passer par git.

2 « J'aime »

Bonjour, je test immédiatement, merci !

Bonjour, je test imédiatement, merci !

J’ai oublié de faire un tag, je m’en occupe.

2 « J'aime »

@b_b Effectivement c’était bien cela, j’ai en plus codé un plugin pour référencer les sites pour l’IA (LLM) pour spip, mais impossible de le déposer sur le le contrib, je n’ai pas les validations de gitLab. En désactivant les plugins, tout est passé au vert et la mise à jour de la BD s’est parfaitement déroulée. MERCI à vous tous !!!