[Résolu] Page blanche après Maj SPIP 3.2.19 => 4.3.1 spip_loader

Bonjour,

J’ai fait une maj SPIP 3.2.19 => 4.3.1 avec spip_loader sur un site avec Travaux activé. Après un court instant, j’ai eu un message ‹ accès interdit › et en dessous un bouton pour se connecter. Et là malheur, page blanche.

Voici le début du spip.log

2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/req/mysql.php:L93:req_mysql_dist()::Pri:debug: Connexion MySQLi vers localhost, base sc4jdrv5513_xxxxmaj, prefixe spip operationnelle
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/req/mysql.php:L183:spip_mysql_set_charset()::Pri:debug: changement de charset sql : SET NAMES 'utf8'
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/inc/flock.php:L652:sous_repertoire()::Pri:ERREUR: creation ../tmp/sessions/
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/inc/flock.php:L652:sous_repertoire()::Pri:ERREUR: creation ../tmp/cache/
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/inc/utils.php:L1651:find_in_path()::Pri:info: include_spip plugins/ajouter_dependances.php non trouve
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/inc/flock.php:L652:sous_repertoire()::Pri:ERREUR: creation ../tmp/cache/xml/
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/xml/analyser_dtd.php:L137:analyser_dtd()::Pri:info: analyse de la DTD ../prive/paquet.dtd 
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/xml/analyser_dtd.php:L137:analyser_dtd()::Pri:info: analyse de la DTD xhtml-lat1.ent 
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/xml/analyser_dtd.php:L137:analyser_dtd()::Pri:info: analyse de la DTD xhtml-symbol.ent 
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/xml/analyser_dtd.php:L137:analyser_dtd()::Pri:info: analyse de la DTD xhtml-special.ent 
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/xml/analyser_dtd.php:L57:charger_dtd()::Pri:info: Analyser DTD SYSTEM ../prive/paquet.dtd (2.024 ms) 18 macros, 19 elements, 17 listes d'attributs, 253 entites
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/inc_version.php:L612:include()::Pri:debug: GET ./?exec=install - ../config/connect.php
2024-08-13 16:46:13 88.161.27.131 (pid 530440) ecrire/src/Afficher/Minipage/Admin.php:L126:page()::Pri:info:  Accès interdit /ecrire/?exec=install
2024-08-13 16:46:37 88.161.27.131 (pid 531497) ecrire/req/mysql.php:L93:req_mysql_dist()::Pub:debug: Connexion MySQLi vers localhost, base sc4jdrv5513_xxxxmaj, prefixe spip operationnelle
2024-08-13 16:46:37 88.161.27.131 (pid 531497) ecrire/req/mysql.php:L183:spip_mysql_set_charset()::Pub:debug: changement de charset sql : SET NAMES 'utf8'
2024-08-13 16:46:37 88.161.27.131 (pid 531497) ecrire/inc_version.php:L612:include_once()::Pub:debug: POST spip.php?page=login - config/connect.php
2024-08-13 16:46:38 88.161.27.131 (pid 531497) ecrire/inc/flock.php:L652:sous_repertoire()::Pub:ERREUR: creation tmp/cache/skel/
2024-08-13 16:46:38 88.161.27.131 (pid 531497) ecrire/inc/utils.php:L1651:find_in_path()::Pub:info: include_spip balise/formulaire_login.php non trouve
2024-08-13 16:46:38 88.161.27.131 (pid 531497) ecrire/inc/utils.php:L1651:find_in_path()::Pub:info: include_spip balise/url_ecrire.php non trouve
2024-08-13 16:46:38 88.161.27.131 (pid 531497) ecrire/balise/url_.php:L296:balise_URL_PAGE_dist()::Pub:info: Calcul url page : connect vaut  ca donne :generer_url_public('identifiants', 'focus=nom_inscription') args 'focus=nom_inscription'
2024-08-13 16:46:38 88.161.27.131 (pid 531497) ecrire/public/compiler.php:L1629:compiler_squelette()::Pub:info: COMPIL (3.209 ms) [prive/login.html] html_05278e20ef6ddda88f93d80931ed55b8.php
2024-08-13 16:46:38 88.161.27.131 (pid 531497) ecrire/inc/utils.php:L1651:find_in_path()::Pub:info: include_spip lity/skins/_simple-dark/mediabox_config_theme.php non trouve

Apparemment, il y a des trucs qu’il ne trouve pas…

Une piste, des idées ?

Merci d’avance

GL

Pour info le plugin travaux est " En travaux 2.0".

Page blanche = erreur PHP. Est-ce que la version de PHP est la bonne pour spip 4.3 ?
Et en désactivant tous les plugins ? (renommer le dossier plugins)

Voir ici sinon Les aides au débuggage de squelettes - SPIP

Merci de ta réponse.

PHP 7.4 et toujours pages blanches en renommant les dossiers plugins et squelettes.

J’ai oublié dans mon précédent message, mais il faut bien sûr vider le cache.

Que donnent les rapports d’erreurs PHP comme indiqué dans le lien ?

J’ai mis l’ancien répertoire session et j’ai été connecté quelques instants. J’ai demandé la maj de la base et maintenant, j’ai toujours une page blanche avec dans l’url : monsite/spip.php?page=login&url=%2Fecrire%2F%3Fexec%3Dupgrade%26arg%3Dcache%26hash%3D2c3c22bb9fd6503cae16eb79acb32194ff8ec83dd886747e2ac57991a067b6a6%26redirect%3D.%252F%253Fexec%253Dupgrade%2526fin%253Doui

Aucunes erreurs php ne s’affiche.

Il manquait sodium dans notre php…

Merci à tous !

1 « J'aime »