[Résolu] Mise à niveau de la Base de données

Bonjour,

Après avoir mis à jour vers la dernière version de SPIP, j’au le messsage:

Action : mise à niveau de votre base SQL
Vous venez de mettre à jour les fichiers SPIP. Il faut maintenant mettre à niveau la base de données du site.

J’ai validé et j’ai cette errur.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Bien cordialement.

Bonjour
pareil avec certain serveur peu puissant,
pas grave : actualisez la page et c’est reparti

Merci.

Bonjour,

Les logs aide à comprendre et il manque peut etre une fonction qui fait planter l’upgrade ?

Non c’est du timeout probablement car on a utilisé quelques fonctions coûteuses en processeur / temps de calcul (hash_hmac) sur cette mise à jour : il suffit de relancer jusqu’à ce que tout soit traité. On a du oublier de mettre un test pour relancer automatiquement par contre d’une part, et d’autre part je n’avais pas pensé que ça allait pouvoir causer ces soucis sur certains hébergements (en local avec nos machines de dev, c’est très transparent tout ça)