Problème sur le plugin "Multilangue facile"

Bonjour,
Je viens de remarquer un problème sur le plugin « Multilangue facile » qui a été rendu compatible SPIP 4.0 en modifiant uniquement les bornes de compatibilité du paquet.xml. Quand ce plugin est activé, il y a un problème pour l’affichage des logos (ils ne s’affichent pas). Je m’en suis rendu compte avec #LOGO_SITE_SPIP mais c’est valable aussi pour les autres logos (articles ou rubriques). Apparemment, le problème viendrait du fichier multilingue_fonctions.php (c’est la surcharge de la fonction inc_chercher_logo() qui pose problème). C’est sûrement à cause de la nouvelle arborescence des logos sur le disque dur.

EDIT : Je confirme. C’est la constante _DIR_LOGOS qui renvoit IMG/ au lieu de IMG/logo/

Ah oui, cette fonction a été revue en Spip 4, le plugin n’est donc pas compatible, merci pour le retour.

Si la surcharge ne concerne que l’affichage des logos via la balise #LOGO_XXX, il y a un pipeline quete_logo_objet prévu pour ça désormais (depuis Spip 3.2 je crois).

Ça devrait éventuellement permettre de maintenir la compat Spip 3 / 4

@paidge il faudrait ouvrir un ticket sur le dépôt du plugin (je viens de les activer) : Issues - multilingue - SPIP on GIT

1 J'aime

Je vais regarder ça, en attendant il suffit de désactiver la « traduction » des logos.