problem with IIS server

Hello, I'm a latinamerican spiper.

[!] I'm not in this list, please respond me direct to me.

I have big problem with IIS server and spip. I can't do nothing couse
a problem with CGI or http header or I really dont know.

People from the hosting service send me this mensage but I dont
understand much and maybe some of you have experience with this kind
of web server.

----------

   I've looked into the issue a bit and it appears that there may be
an issue within the index.php script. The exact cause for the problem
is currently unknown, however, when you comment out lines 197-200 of
the index.php script, the site appears to operate normally. Those
lines are responsible for submitting the HTTP header information such
as the content to be expected by the browser. The syntax looks
correct in the content-type declaration and the only thing I can think
of is that the $GLOBALS variable array contains incorrect or undefined
data. It doesn't appear that the application has any problems with
the OS used for installation, which I originally thought to be a
possible issue. We currently run PHP4, which the requirements specify
version 3, however, this should be a non-issue. The error being
generated is based on an invalid set of HTTP headers, which usually
implies that the "Content-Type" section of output is missing from the
code. This does not appear to be the case, however, if the $GLOBALS
array is empty or the path to where that information is not defined,
it could very well corrupt the HTTP headers being output on lines
197-200. The error could be a side effect of this and I would
recommend researching this section of code further to ensure that all
variables referenced are, in fact, defined. As previously stated,
commenting out these lines allows the script to run without issue.
________________________________

What do you think?

muchas gracias

Santiago Flores wrote:

Hello, I'm a latinamerican spiper.

[!] I'm not in this list, please respond me direct to me.

I have big problem with IIS server and spip. I can't do nothing couse
a problem with CGI or http header or I really dont know.

People from the hosting service send me this mensage but I dont
understand much and maybe some of you have experience with this kind
of web server.

Sorry, what's the initial error?

Pierre

PS: do you know there is a very active (contrary to this list...) spanish list for spip: spip-es@rezo.net

Pierre

It looks like you don't use the latest version of SPIP :
index.php only includes spip.php for the 1.9 versions

Which version of SPIP do you use ? What is your error message
precisely ? Can you test if your error still occurs with the latest
developpment version of spip :
(snapshot available here : http://trac.rezo.net/files/spip/ )

Thanks it would be helpfull for others,

.Gilles
--
2006/12/19, Santiago Flores <santiagoflores@gmail.com>:

Hello, I'm a latinamerican spiper.

[!] I'm not in this list, please respond me direct to me.

I have big problem with IIS server and spip. I can't do nothing couse
a problem with CGI or http header or I really dont know.

People from the hosting service send me this mensage but I dont
understand much and maybe some of you have experience with this kind
of web server.

----------

   I've looked into the issue a bit and it appears that there may be
an issue within the index.php script. The exact cause for the problem
is currently unknown, however, when you comment out lines 197-200 of
the index.php script, the site appears to operate normally. Those
lines are responsible for submitting the HTTP header information such
as the content to be expected by the browser. The syntax looks
correct in the content-type declaration and the only thing I can think
of is that the $GLOBALS variable array contains incorrect or undefined
data. It doesn't appear that the application has any problems with
the OS used for installation, which I originally thought to be a
possible issue. We currently run PHP4, which the requirements specify
version 3, however, this should be a non-issue. The error being
generated is based on an invalid set of HTTP headers, which usually
implies that the "Content-Type" section of output is missing from the
code. This does not appear to be the case, however, if the $GLOBALS
array is empty or the path to where that information is not defined,
it could very well corrupt the HTTP headers being output on lines
197-200. The error could be a side effect of this and I would
recommend researching this section of code further to ensure that all
variables referenced are, in fact, defined. As previously stated,
commenting out these lines allows the script to run without issue.
________________________________

What do you think?

muchas gracias
_______________________________________________
spip-en@rezo.net - http://listes.rezo.net/mailman/listinfo/spip-en

OK, it's spip 1.9.1 rev 7502.

But can you detail your problem : which action are you doing, that
triggers the header error message ?
It's in the private area only ?

Can you also try to install the lastest developpment snapshot on your
server ? A lot of modifications has been done since the "old version"
of September (the svn version is actually 8143 :wink: ). It's possible
that your bug has already been corrected since the 7502 revision of
Spip.

Details of these modifications can be found here :
http://trac.rezo.net/trac/spip/changeset?old_path=spip&old=7502&new_path=spip&new=8143

Thanks for reporting,

.Gilles
---
2006/12/20, Santiago Flores <santiagoflores@gmail.com>:

Hi Giles

Yes, is the actual version for download.

Descargar SPIP - SPIP

2006/12/19, Gilles Vincent <gilles.vincent@gmail.com>:
> It looks like you don't use the latest version of SPIP :
> index.php only includes spip.php for the 1.9 versions
>
> Which version of SPIP do you use ? What is your error message
> precisely ? Can you test if your error still occurs with the latest
> developpment version of spip :
> (snapshot available here : http://trac.rezo.net/files/spip/ )
>
> Thanks it would be helpfull for others,
>
> .Gilles
> --
> 2006/12/19, Santiago Flores <santiagoflores@gmail.com>:
> > Hello, I'm a latinamerican spiper.
> >
> > [!] I'm not in this list, please respond me direct to me.
> >
> > I have big problem with IIS server and spip. I can't do nothing couse
> > a problem with CGI or http header or I really dont know.
> >
> > People from the hosting service send me this mensage but I dont
> > understand much and maybe some of you have experience with this kind
> > of web server.
> >
> > ----------
> >
> > I've looked into the issue a bit and it appears that there may be
> > an issue within the index.php script. The exact cause for the problem
> > is currently unknown, however, when you comment out lines 197-200 of
> > the index.php script, the site appears to operate normally. Those
> > lines are responsible for submitting the HTTP header information such
> > as the content to be expected by the browser. The syntax looks
> > correct in the content-type declaration and the only thing I can think
> > of is that the $GLOBALS variable array contains incorrect or undefined
> > data. It doesn't appear that the application has any problems with
> > the OS used for installation, which I originally thought to be a
> > possible issue. We currently run PHP4, which the requirements specify
> > version 3, however, this should be a non-issue. The error being
> > generated is based on an invalid set of HTTP headers, which usually
> > implies that the "Content-Type" section of output is missing from the
> > code. This does not appear to be the case, however, if the $GLOBALS
> > array is empty or the path to where that information is not defined,
> > it could very well corrupt the HTTP headers being output on lines
> > 197-200. The error could be a side effect of this and I would
> > recommend researching this section of code further to ensure that all
> > variables referenced are, in fact, defined. As previously stated,
> > commenting out these lines allows the script to run without issue.
> > ________________________________
> >
> > What do you think?
> >
> > muchas gracias
> > _______________________________________________
> > spip-en@rezo.net - http://listes.rezo.net/mailman/listinfo/spip-en
> >
>

For information, the problem was due to certain access rights (511 ?)
specifics to his configuration.
The version 1.9.2beta3 works correctly under IIS.

.Gilles

---------- Forwarded message ----------
From: Gilles Vincent <gilles.vincent@gmail.com>
Date: 20 déc. 2006 21:54
Subject: Re: [Spip-en] problem with IIS server
To: Santiago Flores <santiagoflores@gmail.com>

OK, so I think that it's a bug that hasn't been detected / sold yet.

I've created a ticket for it. I hope it will be rapidly corrected.
Here is the link of your bug report : http://trac.rezo.net/trac/spip/ticket/704

.Gilles

--

2006/12/20, Santiago Flores <santiagoflores@gmail.com>:

mmm :frowning: bad news

I change the permisions to the new folders and no more function problem but...

https://www2397.ssldomain.com/gparlamentario/spip/ecrire/

same like before. CGI problem

:frowning:

2006/12/20, Santiago Flores <santiagoflores@gmail.com>:
> Hi giles
>
> I tray with last version, (wow, diferent folder tree)
>
> I didn't get CGI problem but I get another problem
>
> "Fatal error: Call to undefined function: inclure_page() in
> D:\inetpub\gparlamentario\spip\ecrire\public.php on line 20"
>
> you can see it here
> https://www2397.ssldomain.com/gparlamentario/spip/ecrire/
>
> I upload all by filezilla maybe its forget a file, but I dont see the missing.
>
> 2006/12/20, Gilles Vincent <gilles.vincent@gmail.com>:
> > OK, it's spip 1.9.1 rev 7502.
> >
> > But can you detail your problem : which action are you doing, that
> > triggers the header error message ?
> > It's in the private area only ?
> >
> > Can you also try to install the lastest developpment snapshot on your
> > server ? A lot of modifications has been done since the "old version"
> > of September (the svn version is actually 8143 :wink: ). It's possible
> > that your bug has already been corrected since the 7502 revision of
> > Spip.
> >
> > Details of these modifications can be found here :
> > http://trac.rezo.net/trac/spip/changeset?old_path=spip&old=7502&new_path=spip&new=8143
> >
> > Thanks for reporting,
> >
> > .Gilles
> > ---
> > 2006/12/20, Santiago Flores <santiagoflores@gmail.com>:
> > > Hi Giles
> > >
> > > Yes, is the actual version for download.
> > >
> > > Descargar SPIP - SPIP
> > >
> > > 2006/12/19, Gilles Vincent <gilles.vincent@gmail.com>:
> > > > It looks like you don't use the latest version of SPIP :
> > > > index.php only includes spip.php for the 1.9 versions
> > > >
> > > > Which version of SPIP do you use ? What is your error message
> > > > precisely ? Can you test if your error still occurs with the latest
> > > > developpment version of spip :
> > > > (snapshot available here : http://trac.rezo.net/files/spip/ )
> > > >
> > > > Thanks it would be helpfull for others,
> > > >
> > > > .Gilles
> > > > --
> > > > 2006/12/19, Santiago Flores <santiagoflores@gmail.com>:
> > > > > Hello, I'm a latinamerican spiper.
> > > > >
> > > > > [!] I'm not in this list, please respond me direct to me.
> > > > >
> > > > > I have big problem with IIS server and spip. I can't do nothing couse
> > > > > a problem with CGI or http header or I really dont know.
> > > > >
> > > > > People from the hosting service send me this mensage but I dont
> > > > > understand much and maybe some of you have experience with this kind
> > > > > of web server.
> > > > >
> > > > > ----------
> > > > >
> > > > > I've looked into the issue a bit and it appears that there may be
> > > > > an issue within the index.php script. The exact cause for the problem
> > > > > is currently unknown, however, when you comment out lines 197-200 of
> > > > > the index.php script, the site appears to operate normally. Those
> > > > > lines are responsible for submitting the HTTP header information such
> > > > > as the content to be expected by the browser. The syntax looks
> > > > > correct in the content-type declaration and the only thing I can think
> > > > > of is that the $GLOBALS variable array contains incorrect or undefined
> > > > > data. It doesn't appear that the application has any problems with
> > > > > the OS used for installation, which I originally thought to be a
> > > > > possible issue. We currently run PHP4, which the requirements specify
> > > > > version 3, however, this should be a non-issue. The error being
> > > > > generated is based on an invalid set of HTTP headers, which usually
> > > > > implies that the "Content-Type" section of output is missing from the
> > > > > code. This does not appear to be the case, however, if the $GLOBALS
> > > > > array is empty or the path to where that information is not defined,
> > > > > it could very well corrupt the HTTP headers being output on lines
> > > > > 197-200. The error could be a side effect of this and I would
> > > > > recommend researching this section of code further to ensure that all
> > > > > variables referenced are, in fact, defined. As previously stated,
> > > > > commenting out these lines allows the script to run without issue.
> > > > > ________________________________
> > > > >
> > > > > What do you think?
> > > > >
> > > > > muchas gracias
> > > > > _______________________________________________
> > > > > spip-en@rezo.net - http://listes.rezo.net/mailman/listinfo/spip-en
> > > > >
> > > >
> > >
> >
>