Internal server error problem - Need Help

Dear people:

I run a website propelled by spip 3.17 now
upgraded to 3.20. and host at ovh

the site is hosted in a subfolder

the problem suddenly appeared while making an entry of an article and
suddenly there was this internal server error.

i have checked the .htaccess file at it seems ok
I am not sure what the permissions of folders and files [THey should
all be 705 or different]

I have contatcted the Ovh support people but i am left to my own devises.

here is an excerpt from the error log

[Wed Sep 09 01:04:04 2015] [error] [client] [host] Premature end of script headers: spip.php
[Wed Sep 09 01:04:06 2015] [error] [client] [host] script not found or unable to stat:

I am prepared to send you the whole error log file

please advise what i should do


Harsh Kapoor


maybe a pb linked to suexec :

HI Giles,

thanks for pointing to this; I am afraid i dont have full blown server access its a mutual hosting plan. Being non techie user of spip what i can make of this is that it may have to do with the version of php.

This site is an old installation dating to 2007. uses PHP Version 5.2.17

I understand that ovh is no longer going to support versions older than 5.4 / 5.5

I wonder how one migrates to a higher versions. would you point to point to a guide.

In addition there is apparently a requirement for .ovhconfig file at the root level. But i should first migrate to a high version

I wonder if i proceed to do this that i will be able to resolve this problem ?



Just a question about the versions of SPIP
You mentionned the version 3.17 and 3.20 - but these version don’t exist, so I think it’s a mistake
Which are they real version ?

Hi again,
Sorry, I’ve just seen on the website : 3.0.17 and 3.0.20

Before upgrade, have you updated your plugins ?
Have you tried to empty the directory tmp/cache ?
Is you website working without any plugin ? (to check that, just rename « plugins » into « plugins.sav » and empty the cache dir)
You can try these operations on a copy of the site (just copy every files into a subdirectory, and everythink will work perfectly)

My apologies regarding SPIP versions there were 3.0.17 (upgraded to the latest 3.0.20)